Issues with ordering and billing

August 18, Fri
Affected Service: Billing Services Our Website
  • Investigating
    We are investigating this issue, will update shortly.

    11:27, Aug 18 GMT
  • Resolved
    We can confirm this issue is now resolved. Sorry for any inconvenience.

    11:31, Aug 18 GMT
Back to current status